sifrenguvenlimi.com




OSI Katmanları


Protokoller


MAC adresi nedir?


Domain nedir?


High Availability


HTTP-HTTPS Farkı


TCP-UDP Portları


IPv6


CCNA- Giriş


CCNA-Router Konfigurasyonu


CCNA Statik Routing


CCNA Dinamik Routing



Dinamik Routing

Statik routing manuel olarak ihtiyaçları bir yere kadar karşılamaktadır fakat network büyüdükte bu işin zahmeti de artacak ve hata yapma olasılığı yükselecektir.
Dinamik routing işleminde tek tek herbir network için komut yazmaya gerek yoktur. Router cihazına bağlı networkler basit bir komut ile protokol adı ile birlikte cihaza tanıtılır, sonrasını router cihazı en iyi yol seçimi (best path determination) algoritması ile bulur.

Dinamik yönlendirme protokoller 3 türe ayrılır,

- Distance Vektor (RIP, IGRP)
- Link State (OSPF)
- Hybrid (EIGRP)

Distance vector protokoller sahip oldukları routing tablolarını update belirli sürelerde update etme mantığı ile çalışır. Büyük boyuttaki verileri komşulara gönderir ve komşularından da routing tablosu alırlar. Bu işlem bant genişliğinin verimsiz kullanılmasına sebebiyet verir.

Link state protokoller ise, sürekli update yapmak yerine çok küçük “hello” paketleri ile birbirlerinin up durumda olup-olmadıklarını anlarlar.Tüm network topolojisini veritabanlarına kaydederler bu sebeple tüm networke hakimdirler.

Hybrid protokol ise hem distance vector hem link state protokollerin bazı özelliklerini taşır. Buradaki EIGRP protokolü cisco tarafından geliştirilmiştir ve sadece cisco routerlarda çalışır.

Prokollerin özellikleri, davranış biçimleri, yüklenmeleri, olumlu ve olumsuz yanları, protokolleri yüklerken tek tek ayrıntılı bir biçimde anlatılacaktır.


RIP (Routing Information Protocol)

RIP protokolü, en iyi yol seçimi yaparken sadece hop sayısına yani geçtiği router sayısına bakar. Bu hop sayısınında bir limiti vardır.
Bu limit 15’ dir ve 15 den çok sayıda hop geçerek ulaşacağı networke ulaşamaz. Bu durum büyük networklü yapılar için bir handikaptır.
RIP protokolü 30 saniyede bir update yaparak routing tablosunu günceller. Komşularına routing tablosunu gönderir.
Bunu sistem içerisindeki tüm rip yüklü routerların yaptığı düşünüldüğünde band genişliğinin veriminin düşmesi kaçınılmaz olacaktır.
RIP, classfull protokoldür yani yapılandırılması sırasında subnet mask girilmez. Classfull yapıların özelliği, ayarlamalar sırasında subnet mask değerleri girilmemesidir.
Girilen ip aralığına uygun subnet mask, protokol tarafından belirlenerek gönderilir. Bu durum ilk bakışta iyi gibi gözükse de aslında problem yaratmaktadır.
Classless protokolleri anlatırken bundan da bahsedeceğiz. Şimdi gelelim nasıl konfigüre edeceğimize..

Aşağıdaki topolojiyi yeniden gözden geçirelim.

RIP


























Burada tüm ipleri girmemize rağmen yönlendirme olmadığı için Laptop1 ile Laptop2 yi haberleştirememiştik. Şimdi bunu başaracağız..

Router1 cihazının üzerine tıklanarak CLI ekranı açılır ve rip yüklenmesi için aşağıdaki komutlar yazılır,

RIP configuration

















1. Adımda #router rip yazılarak cihaza rip yükleneceği bildirilir.
2. Adımda #network x.x.x.x komutu ile x.x.x.x yerine dahil edilecek networklerin ip adresi yazılır
ve ex komutu ile yükleme kısmından çıkılır. İşte bu kadar basit. Şimdi ise router2 için rip protokolünü oluşturalım,

# router rip
# network 192.168.2.0
# network 192.168.3.0
# ex

Sağda bulunan mektup işaretini 2 bilgisayar üzerine bıraktığımızda sağ alt köşede “succesfull” yazdığını göreceksiniz. Yani 2 bilgisayar artık haberleşebilmektedir.

RIP Success













Enable moda geçip # sh ip route komutu ile routing table kontrol ediniz. Başında R harfi bulunan networkler rip protokolü sayesinde başka routerlardan öğrenilmiş networklerdir.

RIP Load balacing;

Diğer yönlendirme protokoller bir çok farklı değere bakarak en iyi yol değerlendirmesi yaparken rip bildiğiniz gibi sadece hop sayısına bakar. Örneğin bant genişiliği çok yüksek ve 3 routerdan (hop) geçilerek 1 milisaniyede gidilecek yol dururken, bant genişliği çok düşük, en az 20 milisaniyede gidilebilen bir yol sırf 2 routerdan geçeceğim diyerek 2.yolu seçer. Tek kriter hop sayısı olduğu için, rip içi load balacing yapmak çok büyük ihtimaldir. Gidilecek yollardaki geçilecek router sayısı eşit olduğu anda rip protokolü otomatik olarak load balancing yapar yani 10 birim paket gönderecekse, 5 birimini bir yoldan, diğer 5 birimini de diğer yoldan gönderir.

RIP özet:

- En fazla 15 routera kadar destekler
- 30 saniyede bir update
- Classfull bir protokol
- Load Balance ihtimali en fazla olan protokoldür.
- Updateler 255.255.255.255 broadcast adresinden yapılır.
- RIP AD(Administrative Distance) = 120

IGRP (Interior Gateway Routing Protocol)

IGRP en iyi yol seçimi yaparken 5 adet değere bakar. (K1-K2-K3-K4-K5)

=> K1: Bant genişliği
=> K2: Yük
=> K3: Gecikme
=> K4: Güvenilirlik
=> K5: MTU (Maximum Transmission unit)

Bu değerler içinden en etkin olanı K1. Yani bant genişliğidir. Default olarak routerın seri arayüzünün bant genişliği 1.5 Mbit olarak çalışır fakat bu değer değiştirilebilir. Bantgenişliği routerın arayüzüne atanır.

Router(config)# interface FastEthernet 0/1
Router(config-if)# bandwidth “kilobits”

IGRP protokolünün AD değeri 100 dür. AD değerleri öncelik belirtir. Yukarıda rip özet kısmında rip için AD değeri 120 olarak yazılmış idi.
Bunun anlamı rip ile igrp beraber kullanılırsa ÖNCELİK IGRP protokolündedir. AD değeri ne kadar küçük olursa kadar önceliği artar. Yazının sonunda AD değerlerini içeren bir tablo verilecektir.

IGRP default olarak 90 saniyede bir kendi routing tablosunu komşu routerlara update eder. Update işlemi 255.255.255.255 adresinden gerçekleşir. Default olarak 90x3 yani 270 saniye içerisinde update gelmeyen networkleri invalid (geçersiz) sayar fakat routing tablosundan silmez. Toplamda 630 saniye sonra cevap gelmeyen networkleri routing tablosundan siler. Bu 630 saniyelik bekleme süresine flush timer süresi denir. #show ip protocols komutu ile bu süreler görülebilir.

IGRP maksimum olarak 255 hopa kadar çalışır. Ciscoya özeldir, sadece cisco routerlarda çalışır.
IGRP de tıpkı RIP gibi classfull bir protokoldür. Konfigurasyon sırasında subnet mask bilgisi girilmez.
RIP den farklı olarak yapılandırma yaparken bir AS numarası (Autonomus System) girilmelidir. Bu AS numarası aynı sistemde çalışılacağının belirtilmesi için gereklidir. Bu numara girilmez ise iletişim sağlanamaz.

Yapılandırma;
Router(config)# router igrp 100
Router(config-network)# network 192.168.1.0
Router(config-network)# network 192.168.2.0
Router(config-network)# network 192.168.3.0
Router(config-network)#ex

Artık routerda IGRP tanımlanmıştır. -sh ip route komutu ile yönlendirme tablosu kontrol edilmelidir.

OSPF (Open Shortest Path First)

OSPF bir link state protokoldür. Distance vector protokolleri gibi update yapmaz, küçük hello paketleri ile komşularının up olup-olmadıklarını kontrol eder.

Bu hello paketleri 10 saniyede 1 gönderilir ve buradan gelen bilgiler doğrultusunda OSPF database oluşturulur.

Dikkat edeceğiniz üzere database (veritabanı) tabiri kullandık çünkü link state protokoller veritabanı kullanır. Tüm ağın durumu bu veritabanında kayıtlı olur.

Bu protokolde routing bilgilerini toplayıp dağıtan bir merkez router vardır. İsmi Designated Router yani DR olarak geçmektedir. DR ‘nin aktif olmadığı durumlarda BDR devreye girer.(Backup DR)

OSPF çalışma mantığı arealar ile sağlanır. Bu şekilde bir düzen sağlanır ve performans olarak olumlu şekilde katkı sağlar.OSPF’ in merkezi area 0 ‘dır. Area 0, backbone olarak adlandırılır.

Farklı arealara sahip büyük bir network olması durumunda o farklı areaların içindeki routerların bir arayüzü mutlaka area 0 (backbone) ile bağlantılı olmalıdır. Aksi takdirde backbone ile bağı olmayan area ile iletişim sağlanamayacaktır.

Aşağıdaki şekilde de gösterildiği üzere backbone ile bağlantı olmak zorundadır.


OSPF Topology



























OSPF protokolünde komşuluk 7 adımda kurulur. Hello paketleri broadcast adresi ile değil multicast ile gönderilir. (224.0.0.5 multicast adresi) Komşuluk kurulurken DR ve BDR cihaz seçimleri yapılır. En yüksek router ID numarasına sahip olan DR, ikinci en yüksek router ID numarasına sahip olan router ise BDR seçilir. Router ID ise bir routerın aktif arayüzlerinden en yüksek ip adresidir. NOT: Eğer bir routerda loopback adresi tanımlı ise, arayüz ipleri ne olursa olsun router ID, loopback ipsi olur. Arayüzlerin ip’ sinin yüksek yada düşük olamsı durumu değiştirmez. OSFP yapılandırması

OSPF Yapılandırması


























Yukarıdaki örnek topolojide laptop ip leri yeşil, routerların arayüz ipleri ise kırmızı dikdörtgen içine alınmıştır.
Router1 için konfigürasyon,

# router ospf 1
# network 192.168.1.0 0.0.0.255 area 0
# network 192.168.2.0 0.0.0.255 area 0
# exit

Router2 için konfigürasyon,

# router ospf 1
# network 192.168.2.0 0.0.0.255 area 0
# network 192.168.3.0 0.0.0.255 area 0
#exit

0.0.0.255 ifadesi wild card mask belirtir. İleride anlatılacaktır.
Bu işlem ile artık laptoplar aralarında haberleşebilir hale gelmiştir.

# sh ip route komutu ile routing tablosu kontrol edilir.
# debug ip ospf events komutu ile hello paketleri için debugging işlemi yapılır.
# sh ip ospf neighbor komutu ile ospf komşulukları görülür.
# sh ip ospf interface komutu ile arayüz bilgileri görülür.
# ip ospf hello-interval verilecen_saniye komutu ile verilen saniye cinsinden hello paketlerinin gönderimi ayarlanır.
# ip ospf dead-interval verilecen_saniye komutu ile verilen saniye cinsinden dead paketlerinin gönderimi ayarlanır.
# sh ip ospf komutu ile ospf bilgileri görüntülenir.
# sh ip ospf database komutu ile veritabanı görüntülenir.

Not! OSPF protokolünde hello ve dead paketlerinin süreleri karşılıklı olarak aynı olmalıdır. Yoksa komşuluk kurulamaz. (Genelde de hello paket süresinin 4 katı dead paketlerinin süresine eşittir.)

OSPF kuruu networklerde DR olmayan yani standart routerlar sadece birbirlerine hello paketleri gönderebilir. Bunun dışında kalan tüm paketler DR routerının üzerinden geçer. DR routerının down olması durumda ise bu işi BDR routerı ele alır.

Default olarak hello paket gönderim süresi 10 saniyede 1, dead paket gönderim süresi ise 40 saniyedir.

RIP gibi IGRP gibi distance vector grubuna ait protokoller bir güncelleme bilgisi aldıkları zaman, komş routerın arkasındaki routerlar hakkında hiçbir bilgiye sahip değillerdir.
Fakat OSPF’ in de içinde bulunduğu link-state protokoller tüm ağın topolojisini bilirler. Veritabanına sahiplerdir. Bu durumun en büyük dezavantajı ise daha fazla işlem gücü ve daha büyük veritabanı gerektirirler.
OSPF metrik hesabını sadece bant genişliği üzerine kurar. En kısa yolu ise dijkstra algoritmasına göre bulur. OSPF metrik hesabı için cost değerini kullanır.
OSPF’ de RIP gibi bir max-hop kavramı yoktur. Çok büyük miktarda router olan networklerde de çalışabilir. Tabi bu kadar büyüklü ek veritabanı ve işlemci gücü gerektirmektedir.


EIGRP (Enhanced Interıor Gateway Routing Protocol)

İsimden de fark ettiğiniz üzere bu protokol, daha önce işlediğimiz IGRP’ nin geliştirilmiş versiyonudur. RIP’ in ihtiyaçları karşılamayarak RIPv2 olması , ciscoyu da harekete geçirmiş ve IGRP’ nin de yetersiz kalması ile bu protokolü geliştirmiştir.

EIGRP hem ditance vector hem de link state protokol özelliği taşıdığı için hybrid protokol olarak sınıflandırılmaktadır.
EIGRP, aynen distance vector protolleri gibi update mantığı ile çalışır fakat onlar gibi büyük routing tablo paylaşımı yapmaz.Aynen link state protokolü gibi küçük hello paketler ile komşu routerlardan bilgi alır ve o anki durumlarını kontrol eder.

EIGRP hello paketlerini, RTP (Realiable Transport Protokol) isimli, TCP benzeri bir protokol ile gönderir. RTP ‘nin çalışma mantığı TCP ile aynıdır. Cisco tarafından geliştirilmiştir.
Topolojiye dahil olan bir router öncelikle bir query paketi yollar ve dönen reply cevaplarına göre komşu routerlar hakkında bilgi edinerek network yapısı hakkında bilgi sahibi olur.

EIGRP paketleri

Hello
ACK
Update
Query
Reply

EIGRP hello paketlerini, 244.0.0.10 multicast adresi üzerinden gönderir. Karşı routerlardan dönen ACK paketleri ise multicast değil unicast olarak iletilir. ACK paketleri data içermeyen, sadece iletişimin güvenli olması için onay mekanizması sunan paketlerdir.

EIGRP en iyi yol seçimi için metrik hesabında K1 ve K3 (Bandwidth & Delay) değerlerini kullanır. EIGRP için K2, K4 ve K5 değerleri default olarak 0 sayılır.
EIGRP harici protokollerden gelen update bilgilerini kendi routing tablosunda EX (External) olarak işaretler.
EIGRP bütün komşularını Neighbor table’ da ve hedef networke giden tüm yolların bilgisini de topology table’ da tutar. Bu veriler sayesinde en iyi yol seçimi yapar. (Successor)
EIGRP topoloji oluştururken Dual algoritmasının kullanır. Bu algoritma ile kendisine bir en iyi yol (Successor) bir de bu en iyi yola yedek yol (Feasible Successor) seçer.
Successor seçerken bakılan kriter, mümkün olan yollara ait metrik toplamının (herbiri için Feasible Distance denilir) en küçüğünü seçmektir.

EIGRP yapılandırması


EIGRP Yapılandırması



























Yukarıda görüldüğü gibi bir topoloji oluşturulmuş ve ip adresler verilmiştir. Şimdi Router1 cihazına EIGRP yapılandırması uygulayalım,

EIGRP Yapılandırması










Şimdi de Router2 cihazına EIGRP yapılandırması uygulayalım,

EIGRP Yapılandırması












En son mektup işaretini pcler üzerine bırakarak haberleşmenin olup-olmadığını kontrol edelim.



EIGRP Yapılandırması


























Görüldüğü gibi programın sağ alt tarafında hem Laptor1 den Laptop2 ye, hem Laptop2 den Laptop1’ e iletişimin successful olduğu görülüyor.

Şimdi konfigürasyonu adım adım açıklayalım;

1) # router eigrp 100
Bu komut ile routerda eigrp aktif edileceği ve AS numarası olarak 100 kullanılacağı bildirildi. (Router1 ve Router2 yapılandırmasında farklı AS numarası verirseniz cihazlar haberleşemez)
2) # network 192.168.1.0 0.0.0.255
192.168.1.0 networkü dahil edildi. 0.0.0.255 ise wild card mask ifadesidir. Bu ifade subnet mask ifadesinde 0 bitlerin 1 olması ile olur. Örneğin, 255.255.224.0 subnetinin wild card mask ifadesi 0.0.31.255 olur.
3) no auto-summary
Bu komut yazılmaz is eigrp default olarak classfull çalışır. Aynı subnete sahip networkler ile çalışılırken bu durum bir problem çıkarmasada farklı büyüklükte ve subnetteki networklerde iletişim sağlanamaz. Özetle bu komut classfull olan protokolü classless yapar.

EIGRP Load Balacing

EIGRP protokolü, RIP gibi sadece hop count sayısına bakmamaktadır. Bu sebeple aynı metrik değerine sahip yolların olması çok düşük bir ihtimaldir. Bundan ötürü EIGRP’ den RIP gibi “doğal” load balacing yapması beklenemez. Load balance işlemi “variance x” komutu ile yaptırılır. X sayısı burada herhangi bir sayıdır. 2 gibi 3 gibi istenilen değer verilebilir. Peki kaç vermeliyiz? EIGRP gidilecek mesafenin en düşük metrik olanını hesaplar ve paketleri ona göre yönlendirir. Buradaki x sayısı ile bu en düşük metrik değeri, x ile çarpılır ve metrik değeri bu sayının altında kalan yollar arasında load-balance yapılır. Örnek vermek gerekirse, 4 adet yol düşünelim ve bu yolların metrik değerleri aşağıdaki gibi olsun.

EIGRP --------------------------- 100----------------------- Hedef
EIGRP --------------------------- 225----------------------- Hedef
EIGRP --------------------------- 360----------------------- Hedef
EIGRP --------------------------- 430----------------------- Hedef

Yapılandırma yaparken örneğin “variance 3” komutunu kullandınız. Burada en düşük değer olan 100 ile 3 sayısını çarpar ve 100x3=300 değerinden küçük metrikli yollar arasında yük paylaşımı yapılır. Yani 1. Ve 2. Yol arasında yük dengelenmesi yapılır.
O zaman çok büyük verelim bu sayıyı diye düşünüyorsanız hata yaparsınız. Belirli bir değerden sonra paketlerin gidiş süresi çok fazla uzayacağından paketlerin drop edilme yada verinin çok geç gönderilme riski doğmaktadır.

Kullanışlı EIGRP komutları

# sh ip eigrp neighbors
# sh ip eigrp topology
# sh ip route
RIPv2 (Routing Information Protocol Version 2)

RIP protokolünün classful olması gerçek ortam uygulamalarında problemlere yol açması sebebi ile, classless olan RIPv2 çıkartılmıştır.
RIPv2 classless çalışan yani farklı subnete sahip ağlar arasında da yönlendirme yapabilen bir protokoldür. RIP protokolünden en önemli farklarından birisi rip gibi broadcast değil multicast yayın yapar. (multicast adresi 244.0.0.9)
RIP ile ortak yanı ise bu protokol de rip gibi update mantığı ile çalışır.
Updatelerini UDP 520. Port aracılığı ile gerçekleştirir.
Yapılandırmada rip’ ten tek farkı “version 2” komutunuda klenmiş olmasıdır.
Normal rip yapılandırmasının altına “version 2” eklenerek işlem tamamlanır.

Router(config)# router rip
Router(config-router)# network 10.6.2.0
Router(config-router)# network 192.168.1.0
Router(config-router)# version 2
Router(config-router)# ex

Yukarıda da görüldüğü üzere networkler farklı subnetlerde olsalar bile RIPv2 protokolü ile haberleşebilmektedirler. Yapılandırma işlemi bu kadar basit ve kolaydır.
RIPv2 protokolünün, RIP ile en büyük benzer yanı ise, bunun da uzak networke erişirken belirlediği erişim kriterinin sadece hop sayısı olmasıdır. Bu sebeple load-balancing yapma ihtimali, RIP ile aynı orandadır.








Anasayfa|Network|Parola Kontrol|Siber Güvenlik|Linux|Anket|İletişim